Issue Bending doesn't work on Spigot 1.13.2

Cyanspams

Member
Hi there, I haven't used ProjectKorra in years so I may have done something really stupid, but when I installed it on a fresh server when I type /b choose [whatever] it outputs an error and bending doesn't work.

Here is some info:

Error:
[Server thread/ERROR]: null
org.bukkit.command.CommandException: Unhandled exception executing command 'b' in plugin ProjectKorra v1.8.8 for MC 1.13.2+
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:139) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at org.bukkit.craftbukkit.v1_13_R2.CraftServer.dispatchCommand(CraftServer.java:702) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerConnection.java:1641) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:1476) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:45) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.java:1) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.a(SourceFile:10) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:?]
at java.util.concurrent.FutureTask.run(Unknown Source) [?:?]
at net.minecraft.server.v1_13_R2.SystemUtils.a(SourceFile:199) [spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:895) [spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:417) [spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:830) [spigot.jar:git-Spigot-518206a-a5b9c7b]
at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:728) [spigot.jar:git-Spigot-518206a-a5b9c7b]
at java.lang.Thread.run(Unknown Source) [?:?]
Caused by: java.lang.NullPointerException
at com.projectkorra.projectkorra.command.ChooseCommand.execute(ChooseCommand.java:64) ~[?:?]
at com.projectkorra.projectkorra.command.Commands$1.onCommand(Commands.java:109) ~[?:?]
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot.jar:git-Spigot-518206a-a5b9c7b]
... 15 more

Spigot version: multiple 1.13.2 versions
ProjectKorra version: '1.8.8 for MC 1.13.2+'


If you need anything else please contact me.

Thanks,
- Cyan
 

PhanaticD

Member
type /version in game as OP, if it says you are behind, you need to update your server. if you are using a host your options are to
  1. ask host to update their spigot version
  2. build and upload your own spigot jar, which is created using BuildTools: https://hub.spigotmc.org/jenkins/job/BuildTools/lastSuccessfulBuild/artifact/target/BuildTools.jar
  3. download and then upload paper which is like spigot but has a download link and performance improvements https://papermc.io/api/v1/paper/1.13.2/latest/download
 
Top