Important Update for Server Owners

OmniCypher

Staff member
Lead Developer
Plugin Developer
#1
Hello guys, with Minecraft's new 1.12 update being released soon I felt it would be a good idea to give server owners a quick update of what this will entail for their servers. Expect many plugins to break! According to md_5, many deprecated API's are being removed in the spigot/bukkit 1.12 release, this means any plugins utilizing them will need to be updated. In addition, Minecraft servers will no longer support Java versions below 8. You will need to contact your hosts and inform them of this change if you are on Java 7 or below. We are currently working to ensure that ProjectKorra will be up to date and ready for the release.

References: https://www.spigotmc.org/threads/bukkit-craftbukkit-spigot-bungeecord-1-12-pre2-released.240317/
 

OmniCypher

Staff member
Lead Developer
Plugin Developer
#3
So will PK break too If Java -7 is used?
All servers will break if they use Java 7 or below. The plugins themselves do not need to specifically use Java 8 because it is backward compatible (Java 8 can run Java 7 code). However, ProjectKorra will now fully switch over to Java 8 because of the new functionality it allows for.